Loading ...
Sorry, an error occurred while loading the content.

18659SDR# is moving to .NET 4.6

Expand Messages
  • sdrsharp
    Sep 17, 2015
      Hi,

      We have been relying on the .NET Framework 3.5 for quite some time until it's no longer installed by default into the new operating systems. Microsoft also provides minimalist support of this version of the Framework on Windows 10 which handicaped the core and plugin developers in many ways. This also resulted in obscure bugs in the user base. So we moved recently the entire code base to the .NET 4.6 in order to refresh the software and make it compatible with modern operating systems like Windows 10.
      This has many implications:
      • Better performance
      • Better programming API
      • Support of Windows 10
      • Support of Linux and Mac with Mono 4.0 and up
      • End of support of Windows XP and Vista
      • End of support of the ExtIO interface (not portable)

      We coordinated this migration with all the plugins and front-ends developers so no body misses the boat.

      The installation procedure has also changed and now the main package contains a batch file to download the dependencies required to run RTL-SDR.

      This might be disturbing for a few, but the overall impact was judged positive and a better investment for the future, especially with the new API offered by .NET 4.6.


      Cheers,


      The SDR# Team


    • Show all 17 messages in this topic