Loading ...
Sorry, an error occurred while loading the content.

1928Re: 1986 528e with A/T Slipping

Expand Messages
  • ronjkall
    5 Nov 10:30
      zadious,

      thanks for the note on the a/t. how much lucas trans additive would
      you suggest. it's full of atf now. as of this morning, i can only
      start the car in neutral. it will not start in park. is this related
      at all to the trans, or just more devils in the works. ron

      --- In bmwe28@..., Darrell Davis <zadious@y...> wrote:
      > good luck, they do not last that long, i have done 4 5-speed
      conversions, due to the expense of rebuilding the zf. try some lucas
      trans additive, "tall white bottle" i have had great results with
      this product, it really reconditions the bands well... good luck,
      zadious
      >
      > ronjkall <ronjkall@y...> wrote:My A/T just started slipping a
      little bit at high speeds (80 mph) or
      > so. I have 233,000 miles and have changed the fluid and filter
      every
      > 30,000 miles. Is there anything to be serviced on the transmission?
      > Does anyone have an E28 with more than 250,000 miles on an
      automatic
      > transmission?
      >
      >
      > Yahoo! Groups Sponsor
      > To unsubscribe from this group, send an email to:
      > bmwe28-unsubscribe@...
      >
      >
      >
      > Your use of Yahoo! Groups is subject to the Yahoo! Terms of
      Service.
      >
      >
      >
      > ---------------------------------
      > Do you Yahoo!?
      > Exclusive Video Premiere - Britney Spears
      >
      > [Non-text portions of this message have been removed]
    • Show all 4 messages in this topic