Loading ...
Sorry, an error occurred while loading the content.

2366Economy Meter Problems

Expand Messages
  • MrClegg
    May 7, 2004
      Hi All,
      I've got a slight problem with my '85 528i's instrument cluster I
      wonder if anyone might be able to help me with. When I got the car
      the economy meter was occasionally intermittent, it would work but,
      when decelerating, go to the extreme left (as you look at the gauge)
      then not move again almost as if it was stuck, then suddenly it would
      start working again.
      This morning it made no attempt to work at all, looking at the wiring
      diagram in the Haynes book of lies all it says of the economy control
      meter is that the connection leaves the instrument cluster on pin 11
      and is connected to pin 8 of the main engine harness plug and the
      wire colour is yellow and white.
      I suspect that because of the previous intermittent operation that
      the meter is OK but the sender unit or the pressure switch is faulty
      or a connector is corroded. I accept that the wiring could be faulty
      but I view that as the last possible reason as wiring in my
      experience never just breaks for no reason.

      My problem is that I have no idea where the pressure switch or sender
      units are located on the engine, I'm also not certain I'd recognise
      them just by looking, can anyone point me in the right direction, a
      photo would be ideal or a description of where to find them Etc. Etc.
      I can swap sender units with my wife's `87 520i whose economy meter
      works perfectly to determine if the 528's unit is faulty, assuming
      the units are identical, hopeful the problem is connector corrosion.

      I'd welcome thoughts from others who have encountered and solved
      similar problems, my first thought was that it might be an SI board
      related problem, but I can't see why that would be the case as I have
      no other indicators that the batteries are on their way out.
      Ideas anyone?

      Thanks in advance for any suggestions.

      Craig

      1985 528i SE – Classic Luxury
      1987 520i Lux – My Wife's Transport
      1978 Escort 1.6 Ghia – Yellow & Fun
      1980 1.2 Chevette – My Transport
      1998 Triumph Tiger – My Indulgence
    • Show all 3 messages in this topic