Loading ...
Sorry, an error occurred while loading the content.

2939RE: [bmw e28] Ok so I'm puzzled...

Expand Messages
  • Steve Austin
    Oct 16, 2004
      I would change all the fuses and clean all contacts and ground points with a
      good contact cleaner like "detoxit". If this doesn't do the trick, it may
      be the SI batteries in the back of your display have gone/ are going. Can
      be replaced, if a little awkward. There's a detailed procedure in the "BMW
      Enthusiats Companion" by the Car Club of America with some of their
      "Roundel" articles in.

      --Paul

      >From: Craig Newman <mrcleggsbike@...>
      >Reply-To: bmwe28@...
      >To: BMW E28 Group <bmwe28@...>
      >Subject: [bmw e28] Ok so I'm puzzled...
      >Date: Fri, 15 Oct 2004 12:37:23 +0100 (BST)
      >
      >Hi All,
      >Can anyone point me in the right direction?
      >Last night I was off to a restaurant to celebrate my wifes
      >birthday, anyway the car, 528, started first time (as always), I
      >realised when I switched on the lights that I must have left the
      >front fogs on after driving last time I used the car, I shifted
      >too far went passed drive into 3 realised then back into drive.
      >As I went back into drive the instrument lights flickered, and
      >as I pulled away I saw that the speedo wasn't working, neither
      >was the economy guage, everything else on the panel is fine.
      >
      >Today I checked all the fuses, most of the holders and all of
      >the fuses are dirty/have some corrosion but there is nothing
      >blown, I moved them all slightly replaced the cover and took it
      >for a test drive, the speedo worked but after 1/4 of a mile it
      >flickered and ceased to work again. Looking in the Haynes manual
      >and the owners manual it doesn't list the speedo as being
      >connected to any of the fuses!
      >
      >So... is it an instrument display problem and the fuse movement
      >just coincidence? (I don't like coincidences). Should I dump all
      >the fuses, clean all the contacts and fit all new fuses? Learn
      >enough German to worry it into working again? Pray to the gods
      >of old BMWs and hope they fix the problem?
      >
      >Puzzled in Newcastle - and it's raining again!
      >
      >=====
      >MrClegg
      >Newsletter Editor - Northumbria Advanced Motorcyclists
      >www.NAM-Online.org
      >
      >
      >
      >
      >
      >
      >
      >
      >
      >
      >___________________________________________________________ALL-NEW Yahoo!
      >Messenger - all new features - even more fun!
      >http://uk.messenger.yahoo.com

      _________________________________________________________________
      It's fast, it's easy and it's free. Get MSN Messenger today!
      http://www.msn.co.uk/messenger