Loading ...
Sorry, an error occurred while loading the content.

3111RE: [bmw e28] Main Instrument Cluster

Expand Messages
  • ken@kenholyoak.com
    Nov 21, 2004
      Call Steve



      After I spent a bunch of money trying the simple fixes I sent mine to him
      and it was only a couple hundred dollars and has worked perfectly since



      <http://www.dashusa.com/> http://www.dashusa.com/



      (248) 475 9019



      4577 Lapeer Rd. Suite A

      Orion, MI 48359







      _____

      From: gepaul111 [mailto:gepaul111@...]
      Sent: Sunday, November 21, 2004 8:34 PM
      To: bmwe28@...
      Subject: [bmw e28] Main Instrument Cluster




      I have an '86 535i built 3/85 with a spastic instrument cluster.
      None of the following gages seem to be reading the right engine rpm,
      fuel econimizer and speedometer. The odometer and trip odometer
      moves a little. The speedometer gage displays about 20mph and rpm
      gauge displays about 1000rpm going about 60mph.
      I replaced the speed and reference (flywheel) sensors and
      speedometer pulse sensor. all new fuses, cleaned relays and
      connections.
      Any ideas or tips? How many connections are made to the back of the
      cluster.
      Jerry





      To unsubscribe from this group, send an email to:
      bmwe28-unsubscribe@...








      Yahoo! Groups Sponsor






      _____

      Yahoo! Groups Links

      * To visit your group on the web, go to:
      http://uk.groups.yahoo.com/group/bmwe28/

      * To unsubscribe from this group, send an email to:
      bmwe28-unsubscribe@...
      <mailto:bmwe28-unsubscribe@...?subject=Unsubscribe>

      * Your use of Yahoo! Groups is subject to the Yahoo!
      <http://uk.docs.yahoo.com/info/terms.html> Terms of Service.



      [Non-text portions of this message have been removed]
    • Show all 6 messages in this topic