Loading ...
Sorry, an error occurred while loading the content.

4139Re: no spark

Expand Messages
  • graham_e28
    Jan 31, 2006
      --- In bmwe28@..., "littlelorenzo7"
      <littlelorenzo7@y...> wrote:
      >
      > hello, my name is randy a 1985 528e owner, the problem i have with the
      > car is at first the car just turned over and would not start.after
      > talking to the dealer i tried for spark and it was then they suggested
      > fuel pump,so i replaced the external pump and filter without results
      > then the pump and transferpump intank,fuel pressure regulator,the part
      > for cold start, and spark plugs,tried to start still would not start
      > finally ireplaced the sensor over the crank case varoom it started i
      > drove out of town about 200 miles and the car started the same thing
      > over again, turn over and will not start. this time no spark.....
      > tested the fuses now it losing power from the fuse box to the coil
      > could some one please give me a helpful hand my pockets is getting
      > very empty ......
      >
      > respectly
      > please reply ASAP
      >
      > randy w
      >
      Randy,
      Hi, I have an e28 520i which had similar problems after sitting idle.
      Having checked everything I could think of I changed the distributor
      cap and rotor arm (check if the rotar arm has a rev limiter or not -
      if it has there is a spring incorporated in the top of the rotor arm)
      and 'bingo' - she has started first time ever since and runs much more
      evenly.

      You don't say where you are based - I am in UK and got my parts from
      'eurocarparts'- cost was less than GBP £17 plus VAT.
      You can check them out on www.eurocarparts.com and they ship just
      about anywhere, although carriage costs vary. They give an email
      address on the site if you can't find or identify the part on their
      listings eg. they traced a new rubber seal for the boot (trunk)for me
      as mine had perished.

      It would certainly explain why you've no spark.

      All I have to do now is sort out my continuing power problems!!!

      Best of luck - Graham
    • Show all 10 messages in this topic