Loading ...
Sorry, an error occurred while loading the content.
 

1986 528e with A/T Slipping

Expand Messages
  • ronjkall
    My A/T just started slipping a little bit at high speeds (80 mph) or so. I have 233,000 miles and have changed the fluid and filter every 30,000 miles. Is
    Message 1 of 4 , 3 Nov 12:41
      My A/T just started slipping a little bit at high speeds (80 mph) or
      so. I have 233,000 miles and have changed the fluid and filter every
      30,000 miles. Is there anything to be serviced on the transmission?
      Does anyone have an E28 with more than 250,000 miles on an automatic
      transmission?
    • Darrell Davis
      good luck, they do not last that long, i have done 4 5-speed conversions, due to the expense of rebuilding the zf. try some lucas trans additive, tall white
      Message 2 of 4 , 3 Nov 14:34
        good luck, they do not last that long, i have done 4 5-speed conversions, due to the expense of rebuilding the zf. try some lucas trans additive, "tall white bottle" i have had great results with this product, it really reconditions the bands well... good luck, zadious

        ronjkall <ronjkall@...> wrote:My A/T just started slipping a little bit at high speeds (80 mph) or
        so. I have 233,000 miles and have changed the fluid and filter every
        30,000 miles. Is there anything to be serviced on the transmission?
        Does anyone have an E28 with more than 250,000 miles on an automatic
        transmission?


        Yahoo! Groups Sponsor
        To unsubscribe from this group, send an email to:
        bmwe28-unsubscribe@...



        Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.



        ---------------------------------
        Do you Yahoo!?
        Exclusive Video Premiere - Britney Spears

        [Non-text portions of this message have been removed]
      • ronjkall
        zadious, thanks for the note on the a/t. how much lucas trans additive would you suggest. it s full of atf now. as of this morning, i can only start the car in
        Message 3 of 4 , 5 Nov 10:30
          zadious,

          thanks for the note on the a/t. how much lucas trans additive would
          you suggest. it's full of atf now. as of this morning, i can only
          start the car in neutral. it will not start in park. is this related
          at all to the trans, or just more devils in the works. ron

          --- In bmwe28@..., Darrell Davis <zadious@y...> wrote:
          > good luck, they do not last that long, i have done 4 5-speed
          conversions, due to the expense of rebuilding the zf. try some lucas
          trans additive, "tall white bottle" i have had great results with
          this product, it really reconditions the bands well... good luck,
          zadious
          >
          > ronjkall <ronjkall@y...> wrote:My A/T just started slipping a
          little bit at high speeds (80 mph) or
          > so. I have 233,000 miles and have changed the fluid and filter
          every
          > 30,000 miles. Is there anything to be serviced on the transmission?
          > Does anyone have an E28 with more than 250,000 miles on an
          automatic
          > transmission?
          >
          >
          > Yahoo! Groups Sponsor
          > To unsubscribe from this group, send an email to:
          > bmwe28-unsubscribe@...
          >
          >
          >
          > Your use of Yahoo! Groups is subject to the Yahoo! Terms of
          Service.
          >
          >
          >
          > ---------------------------------
          > Do you Yahoo!?
          > Exclusive Video Premiere - Britney Spears
          >
          > [Non-text portions of this message have been removed]
        • ronjkall
          Has anyone heard of using lacquer thinner for a few days of driving around to clean the varnish off the bands to get an older A/T back in business. I was told
          Message 4 of 4 , 12 Nov 12:06
            Has anyone heard of using lacquer thinner for a few days of driving
            around to clean the varnish off the bands to get an older A/T back in
            business. I was told 8-12 oz into the sump after draining off the
            same of ATF, and then changing out the fluid and filter again maybe
            twice in the next month to purge the solvent from the system?

            Is anyone using Redline ATF for these transmissions? And which one,
            they make four different flavors?
          Your message has been successfully submitted and will be delivered to recipients shortly.