Loading ...
Sorry, an error occurred while loading the content.
 

Economy Meter Problems

Expand Messages
  • MrClegg
    Hi All, I ve got a slight problem with my 85 528i s instrument cluster I wonder if anyone might be able to help me with. When I got the car the economy meter
    Message 1 of 3 , May 7, 2004
      Hi All,
      I've got a slight problem with my '85 528i's instrument cluster I
      wonder if anyone might be able to help me with. When I got the car
      the economy meter was occasionally intermittent, it would work but,
      when decelerating, go to the extreme left (as you look at the gauge)
      then not move again almost as if it was stuck, then suddenly it would
      start working again.
      This morning it made no attempt to work at all, looking at the wiring
      diagram in the Haynes book of lies all it says of the economy control
      meter is that the connection leaves the instrument cluster on pin 11
      and is connected to pin 8 of the main engine harness plug and the
      wire colour is yellow and white.
      I suspect that because of the previous intermittent operation that
      the meter is OK but the sender unit or the pressure switch is faulty
      or a connector is corroded. I accept that the wiring could be faulty
      but I view that as the last possible reason as wiring in my
      experience never just breaks for no reason.

      My problem is that I have no idea where the pressure switch or sender
      units are located on the engine, I'm also not certain I'd recognise
      them just by looking, can anyone point me in the right direction, a
      photo would be ideal or a description of where to find them Etc. Etc.
      I can swap sender units with my wife's `87 520i whose economy meter
      works perfectly to determine if the 528's unit is faulty, assuming
      the units are identical, hopeful the problem is connector corrosion.

      I'd welcome thoughts from others who have encountered and solved
      similar problems, my first thought was that it might be an SI board
      related problem, but I can't see why that would be the case as I have
      no other indicators that the batteries are on their way out.
      Ideas anyone?

      Thanks in advance for any suggestions.

      Craig

      1985 528i SE – Classic Luxury
      1987 520i Lux – My Wife's Transport
      1978 Escort 1.6 Ghia – Yellow & Fun
      1980 1.2 Chevette – My Transport
      1998 Triumph Tiger – My Indulgence
    • Paul Sharp
      Hi craig, I own an 86 528i and also had a lot of problems with my instrument cluster. I ended up having to buy a new instrument cluster as they tend to pack
      Message 2 of 3 , May 8, 2004
        Hi craig,

        I own an '86 528i and also had a lot of problems with
        my instrument cluster. I ended up having to buy a new
        instrument cluster as they tend to pack up after what
        is close to 20 years service. You can swap the cluster
        from your wifes 520i to see if that cures the problem.

        Hope that helps you a bit

        Paul Sharp





        ____________________________________________________________
        Yahoo! Messenger - Communicate instantly..."Ping"
        your friends today! Download Messenger Now
        http://uk.messenger.yahoo.com/download/index.html
      • ken@kenholyoak.com
        Dash Electronics will rebuild them - great place and wish I had found them first before I messed and spent a couple hundred $$ trying other ideas
        Message 3 of 3 , May 8, 2004
          Dash Electronics will rebuild them - great place and wish I had found them
          first before I messed and spent a couple hundred $$ trying other ideas

          http://www.dashusa.com/euro_imports.htm

          Kenneth. H. Holyoak
          Information + Insight = Profit
          POB 68633
          Indianapolis, IN 46268-0633

          ken@...
          317-253-7000

          -----Original Message-----
          From: Paul Sharp [mailto:beemerbat@...]
          Sent: Saturday, May 08, 2004 4:45 AM
          To: bmwe28@...
          Subject: Re: [bmw e28] Economy Meter Problems

          Hi Craig,

          I own an '86 528i and also had a lot of problems with
          my instrument cluster. I ended up having to buy a new
          instrument cluster as they tend to pack up after what
          is close to 20 years service. You can swap the cluster
          from your wifes 520i to see if that cures the problem.

          Hope that helps you a bit

          Paul Sharp


               
               
                     
          ____________________________________________________________
          Yahoo! Messenger - Communicate instantly..."Ping"
          your friends today! Download Messenger Now
          http://uk.messenger.yahoo.com/download/index.html


          To unsubscribe from this group, send an email to:
          bmwe28-unsubscribe@...





          Yahoo! Groups Sponsor



          Yahoo! Groups Links
          • To visit your group on the web, go to:
          http://uk.groups.yahoo.com/group/bmwe28/
           
          • To unsubscribe from this group, send an email to:
          bmwe28-unsubscribe@...
           
          • Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.
        Your message has been successfully submitted and will be delivered to recipients shortly.