Loading ...
Sorry, an error occurred while loading the content.
 

Speedometer Problems

Expand Messages
  • scottmaxey1982
    I have a 1986 535i, that I have had for about a year. The radio has always had problems. It will turn off and come back on at various times. Sometimes very
    Message 1 of 6 , May 10, 2004
      I have a 1986 535i, that I have had for about a year. The radio has
      always had problems. It will turn off and come back on at various
      times. Sometimes very often, sometimes nothing happens for a month.
      I have replaced the radio. The only thin I noticed is when the radio
      goes off, the Break Light Check Comes on. So the other day, The
      break light check came on, the radio stopped, and my Speedometer
      stopped working. The break light check has not gone off, the
      radio/Cd player won't work, and I don't know how fast I am going.
      The RPMs work. Does anyone have any ideas about what could be going
      on? I would really appreciate any help. Thanks in advance.
      Scott
      86 535i
      Oregon
    • Matt Meade
      I have an 85 535i, and yesterday when I went to leave for work, the stereo would not come on, and the speedo was not working. I checked the fuses under the
      Message 2 of 6 , May 11, 2004
        I have an 85 535i, and yesterday when I went to leave for work, the stereo would not come on, and the speedo was not working. I checked the fuses under the hood, and the radio fuse was popped. I replaced it, and the stereo came on, and the speedo worked. The second I hit the brakes, the stereo died, and no speedo. Fuse popped again. I messed with the bulb housing for the tail lights, replaced the fuse again, and now everything is working beautifully. Hope this helps...
        Matt
        Ashland, OR
        scottmaxey1982 <scottmaxey1982@...> wrote:
        I have a 1986 535i, that I have had for about a year. The radio has
        always had problems. It will turn off and come back on at various
        times. Sometimes very often, sometimes nothing happens for a month.
        I have replaced the radio. The only thin I noticed is when the radio
        goes off, the Break Light Check Comes on. So the other day, The
        break light check came on, the radio stopped, and my Speedometer
        stopped working. The break light check has not gone off, the
        radio/Cd player won't work, and I don't know how fast I am going.
        The RPMs work. Does anyone have any ideas about what could be going
        on? I would really appreciate any help. Thanks in advance.
        Scott
        86 535i
        Oregon




        To unsubscribe from this group, send an email to:
        bmwe28-unsubscribe@...




        Yahoo! Groups Sponsor

        ---------------------------------
        Yahoo! Groups Links

        To visit your group on the web, go to:
        http://uk.groups.yahoo.com/group/bmwe28/

        To unsubscribe from this group, send an email to:
        bmwe28-unsubscribe@...

        Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.



        ---------------------------------
        Do you Yahoo!?
        Win a $20,000 Career Makeover at Yahoo! HotJobs

        [Non-text portions of this message have been removed]
      • James Brown
        Scott, I had the same problem, my radio shuts off, trip computer stops working and the brake light warning comes on. I think I found the fix though, the brake
        Message 3 of 6 , May 12, 2004
          Scott,


          I had the same problem, my radio shuts off, trip computer stops working and the brake light warning comes on. I think I found the fix though, the brake light socket housing had a rusty contact on it, I tried to sand it clean but it broke apart in my hand. I got new ones and the radio hasn't gone off since. I am still not sure if this was the problem or not but it is worth a try to see if yours are rusted,,,

          Brian


          ---------------------------------
          Do you Yahoo!?
          Yahoo! Movies - Buy advance tickets for 'Shrek 2'

          [Non-text portions of this message have been removed]
        • Paul Sharp
          Hi Scott, I have an 86 528i with very similar problems. For the speedo issue I ended up having to replace the speed transmitter in the rear differential as the
          Message 4 of 6 , May 13, 2004
            Hi Scott,

            I have an 86 528i with very similar problems. For the
            speedo issue I ended up having to replace the speed
            transmitter in the rear differential as the econometer
            guage was moving when changing gear, when all faults
            disappeared and now enjoy very happy motoring. Hope
            that little helps you,

            Paul Sharp,

            Aylsham, Norfolk, UK

            --- scottmaxey1982 <scottmaxey1982@...>
            wrote: > I have a 1986 535i, that I have had for about
            a
            > year. The radio has
            > always had problems. It will turn off and come back
            > on at various
            > times. Sometimes very often, sometimes nothing
            > happens for a month.
            > I have replaced the radio. The only thin I noticed
            > is when the radio
            > goes off, the Break Light Check Comes on. So the
            > other day, The
            > break light check came on, the radio stopped, and my
            > Speedometer
            > stopped working. The break light check has not gone
            > off, the
            > radio/Cd player won't work, and I don't know how
            > fast I am going.
            > The RPMs work. Does anyone have any ideas about what
            > could be going
            > on? I would really appreciate any help. Thanks in
            > advance.
            > Scott
            > 86 535i
            > Oregon
            >
            >
            >
            >
            > To unsubscribe from this group, send an email to:
            > bmwe28-unsubscribe@...
            >
            >
            > Yahoo! Groups Links
            >
            > To visit your group on the web, go to:
            > http://uk.groups.yahoo.com/group/bmwe28/
            >
            > To unsubscribe from this group, send an email to:
            > bmwe28-unsubscribe@...
            >
            > Your use of Yahoo! Groups is subject to:
            > http://uk.docs.yahoo.com/info/terms.html
            >





            ____________________________________________________________
            Yahoo! Messenger - Communicate instantly..."Ping"
            your friends today! Download Messenger Now
            http://uk.messenger.yahoo.com/download/index.html
          • JOE PIETRZAK
            Woo, a fellow Norfolkian! Joe, Norwich P.S. Mine also has the same problem bur after 6 months I ve learnt to live with it! ... Hi Scott, I have an 86 528i with
            Message 5 of 6 , May 13, 2004
              Woo, a fellow Norfolkian!
              Joe, Norwich
              P.S. Mine also has the same problem bur after 6 months
              I've learnt to live with it!


              --- Paul Sharp <beemerbat@...> wrote:
              ---------------------------------
              Hi Scott,

              I have an 86 528i with very similar problems. For the
              speedo issue I ended up having to replace the speed
              transmitter in the rear differential as the econometer
              guage was moving when changing gear, when all faults
              disappeared and now enjoy very happy motoring. Hope
              that little helps you,

              Paul Sharp,

              Aylsham, Norfolk, UK






              ____________________________________________________________
              Yahoo! Messenger - Communicate instantly..."Ping"
              your friends today! Download Messenger Now
              http://uk.messenger.yahoo.com/download/index.html
            • Paul Sharp
              Hi Joe My car is now fully fixed and on the road, lowered by 30mm and lookin good. What car do you have? Kind reggards, Paul ... Woo, a fellow Norfolkian! ...
              Message 6 of 6 , May 15, 2004
                Hi Joe

                My car is now fully fixed and on the road, lowered by
                30mm and lookin' good. What car do you have?

                Kind reggards,

                Paul
                --- JOE PIETRZAK <joepietrzak@...> wrote: >
                Woo, a fellow Norfolkian!
                > Joe, Norwich
                > P.S. Mine also has the same problem bur after 6
                > months
                > I've learnt to live with it!
                >
                >
                > --- Paul Sharp <beemerbat@...> wrote:
                > ---------------------------------
                > Hi Scott,
                >
                > I have an 86 528i with very similar problems. For
                > the
                > speedo issue I ended up having to replace the speed
                > transmitter in the rear differential as the
                > econometer
                > guage was moving when changing gear, when all faults
                > disappeared and now enjoy very happy motoring. Hope
                > that little helps you,
                >
                > Paul Sharp,
                >
                > Aylsham, Norfolk, UK
                >
                >
                >
                >
                >
                >
                >
                ____________________________________________________________
                > Yahoo! Messenger - Communicate instantly..."Ping"
                > your friends today! Download Messenger Now
                > http://uk.messenger.yahoo.com/download/index.html
                >
                >
                > To unsubscribe from this group, send an email to:
                > bmwe28-unsubscribe@...
                >
                >
                > Yahoo! Groups Links
                >
                > To visit your group on the web, go to:
                > http://uk.groups.yahoo.com/group/bmwe28/
                >
                > To unsubscribe from this group, send an email to:
                > bmwe28-unsubscribe@...
                >
                > Your use of Yahoo! Groups is subject to:
                > http://uk.docs.yahoo.com/info/terms.html
                >





                ____________________________________________________________
                Yahoo! Messenger - Communicate instantly..."Ping"
                your friends today! Download Messenger Now
                http://uk.messenger.yahoo.com/download/index.html
              Your message has been successfully submitted and will be delivered to recipients shortly.