Loading ...
Sorry, an error occurred while loading the content.
 

Need Help!!!!

Expand Messages
  • kala2715
    I have an 1985 528 E. I love it! But lately I have been having a problem kkeping the battery charged. I have replaced the battery and the altenator. It ran
    Message 1 of 3 , Jul 2, 2006
      I have an 1985 528 E. I love it! But lately I have been having a
      problem kkeping the battery charged. I have replaced the battery and
      the altenator. It ran great for five days and now its not starting
      again. I can get it to start by rolling and popping the clutch. I have
      no idea what is wrong...please help. I love this car and I don't want
      to junk it I want to restore it
    • bimmernutjob
      Did you replace alternator first, then battery ? a battery running on 10 volts will crank car to start, but will ruin a new alternator quickly. a common
      Message 2 of 3 , Jul 2, 2006
        Did you replace alternator first, then battery ? a battery running on 10 volts will crank car to
        start, but will ruin a new alternator quickly. a common mis-diagnosis.

        Is there a bad ground ? Is positive cable/s free from corrossion ??

        otto in minnesota


        --- In bmwe28@..., "kala2715" <kala2715@y...> wrote:
        >
        > I have an 1985 528 E. I love it! But lately I have been having a
        > problem kkeping the battery charged. I have replaced the battery and
        > the altenator. It ran great for five days and now its not starting
        > again. I can get it to start by rolling and popping the clutch. I have
        > no idea what is wrong...please help. I love this car and I don't want
        > to junk it I want to restore it
        >
      • Kaz Zauver
        Alt has two brushes and if one fail, it will not charge enough for driving but often the charge lamp shows normal. You can just use tester to check the boltage
        Message 3 of 3 , Jul 7, 2006
          Alt has two brushes and if one fail, it will not charge enough for
          driving but often the charge lamp shows normal.
          You can just use tester to check the boltage at the battery when the
          engine is not running. It should be around 12.50 v. Then check when
          engine is running. It should be around 14 v.
          If you get dead battery, there must be something else like shorted
          circuit.

          --- In bmwe28@..., "kala2715" <kala2715@y...> wrote:
          >
          > I have an 1985 528 E. I love it! But lately I have been having a
          > problem kkeping the battery charged. I have replaced the battery and
          > the altenator. It ran great for five days and now its not starting
          > again. I can get it to start by rolling and popping the clutch. I
          have
          > no idea what is wrong...please help. I love this car and I don't
          want
          > to junk it I want to restore it
          >
        Your message has been successfully submitted and will be delivered to recipients shortly.