Loading ...
Sorry, an error occurred while loading the content.
 

Charging System

Expand Messages
  • bmwe28warrior
    Hi I have a 1987 M10 engined 518i Im having a problem getting alternator charge back to the battery Its last point of travel seems to be at the starter motor
    Message 1 of 2 , Apr 10, 1941
      Hi I have a 1987 M10 engined 518i

      Im having a problem getting alternator charge back to the battery
      Its last point of travel seems to be at the starter motor solenoid.
      but goes no further. Failing to reach the battery. Does anyone know if
      the thick positive cable running from battery to solenoid should act as
      both power to starter and return feed from Alternator to battery?
    • doug dykaar
      I had the post where the positive cable attaches to the starter solenoid go rusty, and the car wouldn t start hot. Start cleaning the connections, and/or pull
      Message 2 of 2 , Apr 11, 1941
        I had the post where the positive cable attaches to the starter solenoid go
        rusty, and the car wouldn't start hot. Start cleaning the connections,
        and/or pull the alternator and get it checked at a parts store.

        See if realOEM site shows a picture. I sold my e28, or I'd go look for you.

        Regards,

        doug
        Waterloo, Ontario Canada, eh


        86 951 (http://www.pcaucr.org/forum/post.jsp?postid=2393)
        94 855 turbo
        00 540
        85 535 (sold)
      Your message has been successfully submitted and will be delivered to recipients shortly.