Loading ...
Sorry, an error occurred while loading the content.
 

Oil Pressure light

Expand Messages
  • jforbey
    I ve got a 84 533i that runs well but has one problem: I dunno, car seems to run well with an occasional clatter type noise coming from engine...oil light
    Message 1 of 6 , 9 Nov 20:46
      I've got a '84 533i that runs well but has one problem:
      I dunno, car seems to run well with an occasional clatter type noise
      coming from engine...oil light will sometimes stay on, then go out
      when RPM increases, not turn on or just flicker while engine running.
      Is there any other reason why oil pressure light will act like this?
      Maybe oil drain-back plug in top of canister for filter?

      Has anyone else encountered this problem?

      Thanks,
      jforbey@...
    • Gerald Paul
      Check out the oil pressure switch on the back of the valve cover (near the firewall). If its wet with oil, its probably going bad. ...
      Message 2 of 6 , 10 Nov 06:03
        Check out the oil pressure switch on the back of the
        valve cover (near the firewall). If its wet with oil,
        its probably going bad.
        --- jforbey <jforbey@...> wrote:

        > I've got a '84 533i that runs well but has one
        > problem:
        > I dunno, car seems to run well with an occasional
        > clatter type noise
        > coming from engine...oil light will sometimes stay
        > on, then go out
        > when RPM increases, not turn on or just flicker
        > while engine running.
        > Is there any other reason why oil pressure light
        > will act like this?
        > Maybe oil drain-back plug in top of canister for
        > filter?
        >
        > Has anyone else encountered this problem?
        >
        > Thanks,
        > jforbey@...
        >
        >


        __________________________________________________
        Do You Yahoo!?
        Tired of spam? Yahoo! Mail has the best spam protection around
        http://mail.yahoo.com
      • Pete
        ... Hey jforbey, I would drain the oil and run a magnet through it to see if you find anything unusual. Also, tear open your oil filter and look in there for
        Message 3 of 6 , 10 Nov 08:13
          --- In bmwe28@..., "jforbey" <jforbey@...> wrote:
          >
          > I've got a '84 533i that runs well but has one problem:
          > I dunno, car seems to run well with an occasional clatter type noise
          > coming from engine...oil light will sometimes stay on, then go out
          > when RPM increases, not turn on or just flicker while engine running.
          > Is there any other reason why oil pressure light will act like this?
          > Maybe oil drain-back plug in top of canister for filter?
          >
          > Has anyone else encountered this problem?
          >
          > Thanks,
          > jforbey@...
          >

          Hey jforbey,
          I would drain the oil and run a magnet through it to see if you find
          anything unusual. Also, tear open your oil filter and look in there for
          metal fragments too.

          Last weekend, a friend's '89 325ix was doing the same thing with the
          occasional clatter and oil pressure light flickering and when we
          drained the oil, we found little pieces of metal! They were just flakes
          and slivers... not chunks or big pieces.

          I thought it was something bad in the head, but a BMW master tech
          happened to be at the track when we were doing this and he thought it
          was a spun bearing.

          I know this is probably worst-case senerio, but if you find the same
          stuff in your oil, you might be looking at a new crankshaft.

          Pete

          My site. <http://www.theknese.com/>




          [Non-text portions of this message have been removed]
        • jforbey
          not trying to dwell on past troubles but did he ever fix the problem on the 325ix? jforbey ... noise ... out ... running. ... this? ... find ... there for ...
          Message 4 of 6 , 11 Nov 07:26
            not trying to dwell on past troubles but did he ever fix the problem
            on the 325ix?
            jforbey
            --- In bmwe28@..., "Pete" <pete@...> wrote:
            >
            >
            >
            > --- In bmwe28@..., "jforbey" <jforbey@> wrote:
            > >
            > > I've got a '84 533i that runs well but has one problem:
            > > I dunno, car seems to run well with an occasional clatter type
            noise
            > > coming from engine...oil light will sometimes stay on, then go
            out
            > > when RPM increases, not turn on or just flicker while engine
            running.
            > > Is there any other reason why oil pressure light will act like
            this?
            > > Maybe oil drain-back plug in top of canister for filter?
            > >
            > > Has anyone else encountered this problem?
            > >
            > > Thanks,
            > > jforbey@
            > >
            >
            > Hey jforbey,
            > I would drain the oil and run a magnet through it to see if you
            find
            > anything unusual. Also, tear open your oil filter and look in
            there for
            > metal fragments too.
            >
            > Last weekend, a friend's '89 325ix was doing the same thing with
            the
            > occasional clatter and oil pressure light flickering and when we
            > drained the oil, we found little pieces of metal! They were just
            flakes
            > and slivers... not chunks or big pieces.
            >
            > I thought it was something bad in the head, but a BMW master tech
            > happened to be at the track when we were doing this and he thought
            it
            > was a spun bearing.
            >
            > I know this is probably worst-case senerio, but if you find the
            same
            > stuff in your oil, you might be looking at a new crankshaft.
            >
            > Pete
            >
            > My site. <http://www.theknese.com/>
            >
            >
            >
            >
            > [Non-text portions of this message have been removed]
            >
          • Pete
            Unfortunately, he hasn t yet. He has another 325ix that he crashed at the track a couple of years ago and was just going to swap motors… Then have the one
            Message 5 of 6 , 12 Nov 18:00
              Unfortunately, he hasn't yet. He has another 325ix that he crashed at
              the track a couple of years ago and was just going to swap motors… Then
              have the one that's in there now torn down to find out what was really
              going on.

              Have you had a chance to take a look at the oil that's in your car?

              Pete

              --- In bmwe28@..., "jforbey" <jforbey@...> wrote:
              >
              > not trying to dwell on past troubles but did he ever fix the problem
              > on the 325ix?
              > jforbey
              > --- In bmwe28@..., "Pete" <pete@> wrote:
              > >
              > >
            • John Forbey
              Really I had not yet. Seeing as how it s a daily driver and the light seems to go out when the rpms start to rise, I m trying to find a weekend to jack it up
              Message 6 of 6 , 12 Nov 19:51
                Really I had not yet. Seeing as how it's a daily
                driver and the light seems to go out when the rpms
                start to rise, I'm trying to find a weekend to jack
                it up and pull the pan. A spun bearing is pretty
                scary though.
                I've got another 325e I'm preparing to use while I
                work on my 533i. I'll miss my baby, though. The 325e
                is number 7. '78 323i Alpina, '74 Bavaria, '80 528i,
                '79 Belgian 733i are some of the brethren.

                jforbey


                --- Pete <pete@...> wrote:

                > Unfortunately, he hasn't yet. He has another 325ix
                > that he crashed at
                > the track a couple of years ago and was just going
                > to swap motors… Then
                > have the one that's in there now torn down to find
                > out what was really
                > going on.
                >
                > Have you had a chance to take a look at the oil
                > that's in your car?
                >
                > Pete
                >
                > --- In bmwe28@..., "jforbey"
                > <jforbey@...> wrote:
                > >
                > > not trying to dwell on past troubles but did he
                > ever fix the problem
                > > on the 325ix?
                > > jforbey
                > > --- In bmwe28@..., "Pete" <pete@>
                > wrote:
                > > >
                > > >
                >
                >
                >



                ____________________________________________________________________________________
                Never miss a thing. Make Yahoo your home page.
                http://www.yahoo.com/r/hs
              Your message has been successfully submitted and will be delivered to recipients shortly.