Loading ...
Sorry, an error occurred while loading the content.
Advanced Search
Author
Subject
Message
Special notice only

Advanced Search
  • Hi everyone, I have an absolutely original April 1982 520iA. 125000 miles. I am the 4th owner and I have full service history.Car is ex UK. Silver with bronze tint windows. Factory mags. Electric windows. Full adjust front seats. Full adjust steering column.Rev counter but no vac gauge (econometer). Blue Houndstooth cloth seats.No sunroof.Early version of climate control ( no air...
    David Field Apr 29, 2006
  • Robert Allan wrote: Hello, I've been searching and searching and i seem to run into alot of contradictory information about the market price for a e28 528i in Australia at the moment. some places say 4-7000 and others 2-3500 now i know i bought mine for 2500 on the road..... but that was pretty cheap and i am considering putting a couple of grand into it (bushes shocks tyres etc...
    David Field Nov 21, 2005
  • --- In bmwe28@^$1, Roderick Tuason wrote: > looks like all the header bolts are in...not sure on the O2 Sensor...I'm at work and cant' get into to engine compartment just yet > > Blake Nancarrow wrote:On Thursday 9 June 2005 11:40 AM, Roderick Tuason > wrote: > > Yes all of them are in...the noise is coming from > the passenger side close to the firewall > > Oh, are all the header...
    okareka12000 Jun 10, 2005
  • Hi Guys, Thanks for your help.I've done a bit of research today.The sensor is called temperature switch 0*C according to my Haynes book - and not fitted to my car according to my BMW dealers computer!! It is linked to cold start valve, temperature time switch and diode relay. I have removedv the sensor, cleaned it and re rivetted the contacts. Now the car starts like it should do...
    okareka12000 Jun 7, 2005
  • G'day again.Some time back, there was discussion about hotter spark plugs for use with low octane fuel. Our available fuels are 91 unleaded and 96 unleaded. Any body got recommendations for best fuel to use and best spark plugs to go with that fuel please? regards, dave NZ
    okareka12000 Jun 6, 2005
  • Thanks for the advice David. Is there an easy way to check/fix the problem? Dave NZ
    okareka12000 Jun 6, 2005
  • G'day everyone,On the thermostat housing of my '82 520i there are 2 sender units. One has just one electrics lead to it, the other has 2 terminals and 4 leads. This one has a purple top, and more important corroded terminals ( blade type).I am picking that the first one is the sender unit for the gauge ( which reads ok), but does the second one have anything to do with cold...
    okareka12000 Jun 5, 2005
  • Hi everyone,My Haynes manual refers to a code plug on the back of the cluster,looks like it plugs into the back of the speedo, at the bottom.Neither of my 520i's have got this.Is this correct?Anyone know what this code plug does?And most important if I get one will it fix my rev counter, which still refuses to work ( both cars,all combinations of rev counter and instrument cluster...
    okareka12000 May 23, 2005
  • ...batteries and they are then easy to charge/replace without removal of instruments. Timoshenko ----- Original Message ----- From: "okareka12000" To: Sent: Friday, April 29, 2005 10:00 AM Subject: [bmw e28] Instrument cluster > Greetings, When you replace the batteries, don...
    David Field May 3, 2005
  • Greetings, When you replace the batteries, don't forget to charge them first! Sounds obvious, but nobody told me - so then you have to take the cluster out and apart again. I still have a problem getting my rev counter to work.I have replaced the batteries in the pcb, no rev counter. I have tried a known good rev counter from another car, still doesn't work.I have been told of...
    okareka12000 Apr 29, 2005