Loading ...
Sorry, an error occurred while loading the content.
Advanced Search
Author
Subject
Message
Special notice only

Advanced Search
  • You can get them in UK from GSF or Eurocar parts (check out their websites) - about �5 each. >From: "Steve Haygood" >Reply-To: bmwe28@^$1 >To: >Subject: Re: [bmw e28] OIl Change for M535i >Date: Mon, 28 Feb 2005 18:47:27 -0500 > >I have them for 3.85 oem with all the orings etc. Change every 3000 miles >or 5000 KM, not muc good if you are in the UK...:-( >Steve > ----- Original...
    Steve Austin Feb 28, 2005
  • Check for vacuum leaks. Check between air filter and engine and engine and throttle body. --Paul >From: "Joel T. Gonzalez" >Reply-To: bmwe28@^$1 >To: bmwe28@^$2 >Subject: Re: [bmw e28] loping idle >Date: Thu, 6 Jan 2005 09:21:58 -0800 (PST) > >Check the throttle position switch and test it out. This could be a >possible malady. > > Best regards, > > Joel T. Gonzalez > San Antonio...
    Steve Austin Jan 12, 2005
  • No idea if it can be taken apart easily but would like to know what the problem turns out to be. Keep in touch. --Paul >From: "okareka12000" >Reply-To: bmwe28@^$1 >To: bmwe28@^$2 >Subject: [bmw e28] Wash/wipe 82 520i >Date: Wed, 17 Nov 2004 06:01:14 -0000 > > >Thanks for that info, Paul. Do you know if the relay can be taken >apart easily (in case it's a loose solder joint problem...
    Steve Austin Nov 17, 2004
  • Wash/Wipe Motor - could be too much grease or could be wash/wipe relay. --Paul >From: "okareka12000" >Reply-To: bmwe28@^$1 >To: bmwe28@^$2 >Subject: [bmw e28] Tacho/Service indicator not working 82 520I >Date: Tue, 16 Nov 2004 08:50:06 -0000 > > >Hi y'all,Can anyone help please? I've put new batteries in the pcb >behind the dash - no difference.Someone told me that it could be the...
    Steve Austin Nov 16, 2004
  • Broken sensor connection/wiring would be my guess. Check and clean all grounds and fuse wouldn't hurt either. Paul >From: "Chris Trevelyan" >Reply-To: bmwe28@^$1 >To: >Subject: [bmw e28] Brake Warning Light...? >Date: Wed, 10 Nov 2004 16:46:19 -0800 > > From time to time, my brake warning light (on dash) flickers on >and off - esp. when I've just started the car up, but also at...
    Steve Austin Nov 15, 2004
  • Hi I'm in England where they used to sell this model. I have a 1985 528i with 126k miles on the clock. I've had great pleasure from it for over 2 years and it runs like a dream. Regular maintenance is the key. Particularly oil and oil filter changes at 5000 miles max interval. After trying various oils I now use Mobil 1 (although syntethetics are not recommended by BMW) and it...
    Steve Austin Oct 25, 2004
  • Barry Look at message number 2795 and follow the link in that message. You can get the pump and strainer (intank filter that attaches to the pump) from Rockauto.com. Click on Cheverolet, click on 1976, click on Vega and click on fuel/air. Pump is Airtex E3900 and Strainer is FS100 or FS101. I used FS101 it is long and thin and works fine but FS100 is more like the shape used by BMW...
    Steve Austin Oct 19, 2004
  • Ken I have heard of people having cracked blocks speciality welded. Don't know how much that would cost though. Good luck. Paul en@^$1 >Reply-To: bmwe28@^$2 >To: >Subject: [bmw e28] 735iL >Date: Sat, 16 Oct 2004 10:19:53 -0500 > >The 93 735iL turns out to need more than a water pump. The block is cracked >where the water pump attaches. > > > >I have several options, hunt down new...
    Steve Austin Oct 19, 2004
  • Henky Change fule pump fuse - make sure it is sitting tightly in it's, cleaned, "holder". Then clean all grounds - particularly engine ground, ground under rear seat and ground by battery. I'm no expert but if the pumps work when you jump them and the fuel pump fuse and relay are working must be ground/wiring problem. --Paul >From: "henkytonk" >Reply-To: bmwe28@^$1 >To: bmwe28@^$2...
    Steve Austin Oct 19, 2004
  • Hi Sounds like Fuel Pump Relay to me. Paul >From: "henkytonk" >Reply-To: bmwe28@^$1 >To: bmwe28@^$2 >Subject: [bmw e28] I'm new and need some >Date: Mon, 18 Oct 2004 05:16:59 -0000 > > >Hello there, my name is Henky, I live in Jakarta, Indonesia. >Please help. I own E28 year 1988. I've some problem with the >electricity. The gas pump is not responding. The first (under) and >the...
    Steve Austin Oct 19, 2004